Strange error loading brcmfmac on yocto krogoth [ANSWERED]

Moderators: Oren.R, Eran.M, fradensky

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Strange error loading brcmfmac on yocto krogoth [ANSWERED]

Postby pmarzo » Tue Mar 14, 2017 11:36 am

When the module starts on our custom hardware the module brcmfmac reports this error:
brcmfmac: F1 signature read @0x18000000=0x1531a9a6
brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

If I unload the module and reload it again everything works great
sleep 5
rmmod brcmfmac
echo "loading broadcom wifi driver"
modprobe brcmfmac
sleep 5

brcmfmac: F1 signature read @0x18000000=0x1531a9a6
brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Nov 14 2016 00:32:49 version 7.45.41.32 (r662793) FWID 01-8b473c3f
brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code (0x30 0x30)

I've fixed it just doing that on my startup script but I am a bit worried about the error.
It does not happen on the evaluation board and it did not happen on yocto fido on our custom hardware either.

Do you think it is something to worry about?
Can it be fixed anyway?

Best Regards, Pedro

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby fradensky » Tue Mar 14, 2017 1:07 pm

The error should be fixed by the following kernel commit:
https://github.com/varigit/linux-2.6-im ... 1fa80073d2

Please update you kernel sources, rebuild DTB file and install to NAND/eMMC

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby pmarzo » Mon Mar 20, 2017 8:42 am

Ok, I am using branchimx-rel_imx_4.1.15_2.0.0_ga-var01 (yocto krogoth-r2) and just done a git pull but I do not see this commit on the log.
I see it is properly fixed at krogoth-r1 branc(1.2). Which branch should we use for deployment/production release?

Best Regards, Pedro

Eran.M
Posts: 140
Joined: Tue Jan 26, 2016 10:49 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby Eran.M » Mon Mar 20, 2017 9:22 am

Hi Pedro.
Here is the relevant commit in the imx-rel_imx_4.1.15_2.0.0_ga-var01 branch:
https://github.com/varigit/linux-2.6-im ... 295543ccae

I suggest using the latest commit in imx-rel_imx_4.1.15_2.0.0_ga-var01.

Regards,
Eran

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby pmarzo » Mon Mar 20, 2017 9:40 am

It is strange, I am on this branch (krogoth r2)

git branch
imx-rel_imx_4.1.15_1.1.0_ga-var02
* imx-rel_imx_4.1.15_2.0.0_ga-var01

However the file arch/arm/boot/dts/imx6ul-var-dart.dtsi is just 50 lines long, it includes file "imx6ul-imx6ull-var-dart-common.dtsi".
My file is the same as on the web https://github.com/varigit/linux-2.6-im ... -dart.dtsi

Your commit does not seems to match this file

Best Regards, Pedro

Eran.M
Posts: 140
Joined: Tue Jan 26, 2016 10:49 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby Eran.M » Mon Mar 20, 2017 9:48 am

That's because of a later commit: https://github.com/varigit/linux-2.6-im ... df31b68864
That's how it should be - just make sure you are using the latest commit.

Do you still get the error when using the latest commit?

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby pmarzo » Mon Mar 20, 2017 10:06 am

Yes, I get this error and I I have this commit on my compiled kernel.

Best Regards, Pedro.

Eran.M
Posts: 140
Joined: Tue Jan 26, 2016 10:49 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby Eran.M » Mon Mar 20, 2017 10:44 am

Please register and post your issue as a ticket in our customer portal below:
http://www.variscite.com/support/varisc ... mer-portal

Please attach a full boot log, make sure you choose the SOM you are using and specify if the issue relates to either software or hardware. The system will dispatch your support ticket accordingly.

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Strange error loading brcmfmac on yocto krogoth

Postby fradensky » Thu Apr 06, 2017 12:56 pm

Check J2 connection of pin 85. It should be sourced with 32Khz signal for Wi-Fi.
This is documented in data sheet, page 22. You can connect it to J2.28 if this pin is not used.


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 2 guests

cron