Search found 19 matches

Go to advanced search

by y.yemelyanov
Wed Feb 22, 2017 11:02 am
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

Re: Poor 2D graphics performance in QT

Hi Felix,

Yes, thank you! Killing Weston helps a lot - mouse is not lagging any more.
The button look different though, kinda flat, but I suppose we can live with that.

On a general note, looks like Weston is either not optimised, or doesn't work well with AM33 hardware?
by y.yemelyanov
Wed Feb 15, 2017 4:45 pm
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

Re: Poor 2D graphics performance in QT

Ok, I have some update on the issue. Basically, I don't think the problem is with any of our programming. The problem is either with QT itself or with hardware 2d graphics performance. Here is an easy way to reproduce poor cursor speed on VAR-DVK: 1. From Matrix UI go to QT5 shortcut 2. Start "...
by y.yemelyanov
Thu Feb 02, 2017 8:36 pm
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

Re: Poor 2D graphics performance in QT

Hi Felix, Yes, tried this, but the result is unchanged. I tried compiling the app into Debug and Release, but that does not affect it. I also tried DVK dev kit as well as our custom board, different mice, different resolutions, nothing helps. The only difference I found was setting all the elements ...
by y.yemelyanov
Thu Jan 26, 2017 1:36 pm
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

Re: Poor 2D graphics performance in QT

Hi Felix, Thanks for your reply. Buit-in QT apps also have this problem, but because the window and/or the actual UI elements are small in size it is less noticable. If you look closely on the Calculator app, you can see how cursor is slowing down too. Perhaps you will start noticing this after watc...
by y.yemelyanov
Tue Jan 24, 2017 3:05 pm
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

Re: Poor 2D graphics performance in QT

Hi Felix,

We are using Krogoth. Even the one from your FTP has this issue.
by y.yemelyanov
Tue Jan 24, 2017 12:22 pm
Forum: Yocto
Topic: [SOLVED] Poor 2D graphics performance in QT
Replies: 12
Views: 8902

[SOLVED] Poor 2D graphics performance in QT

Hello, We are trying out QT 5 application on VAR-SOM-AM33 (600 MHz clock). We are seeing very strange performance issues - Create a simple QT Widget application with pre-generated form-window. Place 3-5 buttons on the form of a fairly large size 50x30 px or a bit larger. Run on VAR-SOM-AM33. As soon...
by y.yemelyanov
Wed Jan 11, 2017 10:43 pm
Forum: Yocto
Topic: [ANSWERED] fbset not working in Krogoth
Replies: 1
Views: 2559

[ANSWERED] fbset not working in Krogoth

Hi, We need to be able to chnage the resolution and pixel clock during runtime. On older Sitara SDK 7 and 8 (kernel 3.12) we used "fbset" utility. In Krogoth, however, that doesn't work any more. fbset is present, it takes the commands, but display doesn't change. We are able to change the...
by y.yemelyanov
Tue Dec 27, 2016 7:08 pm
Forum: Yocto
Topic: [Solved] Flashing Krogoth to NAND
Replies: 8
Views: 6133

Re: Flashing Krogoth to NAND

Good news, thank you. I was able to recompile the image that fits 256 Mb NAND from your source in varigit as well. Could you please let me know how to include an SFTP server into the image? I am getting "sh: /usr/lib/openssh/sftp-server: No such file or directory" error in QT Creator when ...
by y.yemelyanov
Tue Dec 27, 2016 7:00 pm
Forum: Yocto
Topic: Error compiling input-utils_1.0.bb
Replies: 2
Views: 3595

Re: Error compiling input-utils_1.0.bb

Thanks, Felix.

I tried this as well as some other things and it didn't help.

Eventually I managed to get get it to compile on Ubuntu 14.04. instead of 16.04.
by y.yemelyanov
Sat Dec 24, 2016 1:49 pm
Forum: Yocto
Topic: Error compiling input-utils_1.0.bb
Replies: 2
Views: 3595

Error compiling input-utils_1.0.bb

Hi, I am trying to recompile Krogoth FS following this http://variwiki.com/index.php?title=VAR-SOM-AM33_Yocto_Krogoth_Build I get this error, that I cannot resolve: ERROR: input-utils-1.0-r0 do_compile: oe_runmake failed ERROR: input-utils-1.0-r0 do_compile: Function failed: do_compile (log file is ...

Go to advanced search

cron