System hangs at reboot [SOLVED]

Moderators: Oren.R, Eran.M, fradensky

Oren.R
Posts: 65
Joined: Tue Dec 16, 2014 7:47 pm

Re: System hangs at reboot

Postby Oren.R » Wed Oct 12, 2016 11:23 pm

Hi Thomas,
have you managed?

chrisw957
Posts: 30
Joined: Fri Aug 28, 2015 8:21 pm

Re: System hangs at reboot [SOLVED]

Postby chrisw957 » Tue Feb 28, 2017 7:08 pm

We see something similar with a i.mx6q. Using a custom carrier board as well, but it performs fine otherwise, even under heavy load, so I doubt a power supply issue. If we put strace in from of killall5 in sendsigs init script, we see it locks up with:

Code: Select all

rt_sigaction(SIGTERM, {SIG_IGN, [TERM], SA_RESTORER|SA_RESTART, 0x76e2eb70}, {SIG_DFL, [], 0}, 8) = 0                                                           
rt_sigaction(SIGSTOP, {SIG_IGN, [STOP], SA_RESTORER|SA_RESTART, 0x76e2eb70}, 0x7eb54a84, 8) = -1 EINVAL (Invalid argument)                                     
rt_sigaction(SIGKILL, {SIG_IGN, [KILL], SA_RESTORER|SA_RESTART, 0x76e2eb70}, 0x7eb54a84, 8) = -1 EINVAL (Invalid argument)                                     
mlockall(MCL_CURRENT|MCL_FUTURE)        = 0                                     
kill(-1, SIGSTOP


When it starts doing this, it will generally keep doing it for awhile.

Our kernel is pinned to this commit:
https://github.com/varigit/linux-2.6-im ... c7e273f7bd

I see there is a subsequent commit which enabled CONFIG_POWER_RESET and CONFIG_POWER_RESET_SYSCON_POWEROFF. I already have CONFIG_POWER_RESET enabled, but I will try adding CONFIG_POWER_RESET_SYSCON_POWEROFF.


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 2 guests