Use systemd [SOLVED]

Moderators: Oren.R, Eran.M, fradensky

hwaddle
Posts: 9
Joined: Tue Jul 12, 2016 5:52 pm

Re: Use systemd [SOLVED]

Postby hwaddle » Mon Nov 14, 2016 7:53 pm

Again thanks for the quick response! That fixed worked great, I hate to keep asking questions but is there anything in particular that would cause the Bluetooth interface to not work properly with systemd? When I follow the instructions on the "How-to" section of the krogoth developer guide and run hciconfig I get nothing.

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Use systemd [SOLVED]

Postby fradensky » Tue Nov 15, 2016 8:42 am

Hi,

We have our own bluetooth-variscite startup script to configure and start bluetooth. It is not installed in systemd configuration. See meta-variscite-mx6/recipes-core/initscripts/files/imx6ul-var-dart/variscite-bluetooth.

Also, keep in mind that BT/WIFI are not available in SD boot mode, you should be running from eMMC/NAND.

Felix.

hwaddle
Posts: 9
Joined: Tue Jul 12, 2016 5:52 pm

Re: Use systemd [SOLVED]

Postby hwaddle » Thu Nov 17, 2016 2:41 pm

I was booting from nand, I have a custom board I usually use but wanted to make sure that the issue wasn't my hardware. So currently the only way to access the Bluetooth interface is through using sysvinit?

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Use systemd [SOLVED]

Postby fradensky » Thu Nov 17, 2016 2:57 pm

We're working on Bluetooth support under systemd. It should be ready pretty soon. I'll update this thread when it's available. For the time being please use sysvinit.

hwaddle
Posts: 9
Joined: Tue Jul 12, 2016 5:52 pm

Re: Use systemd [SOLVED]

Postby hwaddle » Thu Nov 17, 2016 3:02 pm

Thanks for the quick responses and the support!

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Use systemd [SOLVED]

Postby fradensky » Sun Nov 20, 2016 2:31 pm

I've pushed relevant changes to git, please update meta-variscite-mx6 as explained in the wiki and rebuild SD.

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Use systemd [SOLVED]

Postby fradensky » Sun Nov 20, 2016 2:32 pm

Make sure to copy updated var-setup-release.sh from meta-varaiscite-mx6.

hwaddle
Posts: 9
Joined: Tue Jul 12, 2016 5:52 pm

Re: Use systemd [SOLVED]

Postby hwaddle » Mon Nov 21, 2016 9:59 pm

Just tested and it is working for me. Thanks for the update.


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 2 guests