eth0 does not work under yocto krogoth

Moderators: Oren.R, Eran.M, fradensky

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

eth0 does not work under yocto krogoth

Postby pmarzo » Mon Dec 12, 2016 1:44 pm

Hi, I have just updated from fido to krogoth and seems the eth0 has stopped working.
I followed the instructions here http://variwiki.com/index.php?title=DART-6UL_Yocto_Krogoth_R1_build to create a core-image-minimal image, flash it on a module and put it on the evk board. eth0 does not seem to get an ip address through udhcpc and it doesn't make a ping event if I put a fixed IP address. eth1 works perfectly fine.
With yocto fido both eth0 and eth1 work perfectly.

eth0
# udhcpc -i eth0
udhcpc (v1.24.1) started
Sending discover...
fec 20b4000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
Sending discover...
Sending discover...
Sending discover...
Sending discover...

~# udhcpc -i eth1
udhcpc (v1.24.1) started
Sending discover...
Sending select for 192.168.11.61...
Lease of 192.168.11.61 obtained, lease time 86400
/etc/udhcpc.d/50default: Adding DNS 192.168.11.251
/etc/udhcpc.d/50default: Adding DNS 192.168.11.79

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: eth0 does not work under yocto krogoth

Postby fradensky » Mon Dec 12, 2016 1:57 pm

Hi,

Do you use systemd or systemV init in core-image-minimal ?

Felix.

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: eth0 does not work under yocto krogoth

Postby pmarzo » Mon Dec 12, 2016 2:19 pm

I guess it is systemV, I do not change anything from the wiki instructions.
Variscite module revision: 1.21
EVK revision: 1.2

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: eth0 does not work under yocto krogoth

Postby fradensky » Mon Dec 12, 2016 2:53 pm

I'll check and get back to you.

Felix.

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: eth0 does not work under yocto krogoth

Postby fradensky » Tue Dec 13, 2016 5:41 pm

Hi,

I cannot reproduce the problem here, both interfaces work for me in Krogoth. When cable is connected to eth0 (marked as Ethernet 2 on carrier board) what is the status of the LEDs ? Please send the output of "dmesg | grep eth".

Felix.

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: eth0 does not work under yocto krogoth

Postby pmarzo » Wed Dec 14, 2016 12:13 pm

This is the output I see on the screen when I pluged eth0 (eth1 is unplugged)

root@0AM162100A00:~# fec 20b4000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

root@0AM162100A00:~# dmesg | grep eth0
fec 20b4000.ethernet eth0: registered PHC device 0
fec 20b4000.ethernet eth0: Freescale FEC PHY driver [Micrel KSZ8081 or KSZ8091] (mii_bus:phy_addr=20b4000.ethernet:03, irq=-1)
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
fec 20b4000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready


ifconfig eth0
eth0 Link encap:Ethernet HWaddr F8:DC:7A:0A:D8:F1
inet6 addr: fe80::fadc:7aff:fe0a:d8f1%31799552/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:3 dropped:0 overruns:0 frame:3
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:2700 (2.6 KiB)

Green LED is on, Orange LED is blinking

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: eth0 does not work under yocto krogoth

Postby pmarzo » Wed Dec 14, 2016 12:14 pm

Forgot to say it is a module running from NAND and WIFI option.

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: eth0 does not work under yocto krogoth

Postby fradensky » Wed Dec 14, 2016 2:08 pm

Hi,

Tested in NAND+WIFI configuration, both interfaces get IP addresses via DHCP. Please post the contents of /etc/network/interfaces.

Felix.

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: eth0 does not work under yocto krogoth

Postby pmarzo » Thu Dec 15, 2016 9:14 am

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# Wireless interfaces
iface wlan0 inet dhcp
wireless_mode managed
wireless_essid any
wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf


# Wired or wireless interfaces
auto eth0
auto eth1
iface eth0 inet dhcp
iface eth1 inet dhcp

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
iface usb0 inet static
address 192.168.7.2
netmask 255.255.255.0
network 192.168.7.0
gateway 192.168.7.1

# Bluetooth networking
iface bnep0 inet dhcp



As you can see there are errors on eth0 and no errors on eth1. I use the same ethernet cable and plug in one time on eth0 and another time on eth1.
eth1 gets IP address by dhcp but eth0 does not.

~# ifconfig
eth0 Link encap:Ethernet HWaddr F8:DC:7A:0A:D8:F1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:116 dropped:0 overruns:0 frame:116
TX packets:315 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:105138 (102.6 KiB)

eth1 Link encap:Ethernet HWaddr F8:DC:7A:0A:D8:F0
inet addr:192.168.11.104 Bcast:192.168.11.255 Mask:255.255.255.0
inet6 addr: fe80::fadc:7aff:fe0a:d8f0%1995839184/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:236 errors:0 dropped:15 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26268 (25.6 KiB) TX bytes:1908 (1.8 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1%1995839184/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

pmarzo
Posts: 15
Joined: Tue Nov 15, 2016 10:44 am

Re: eth0 does not work under yocto krogoth

Postby pmarzo » Thu Dec 15, 2016 10:21 am

There seems to be a hardware problem, I have tried with another EVK (fortunately we have two) and both ethernets, work so it seems there is something wrong with ETH2 on one EVK.

Anyway it is strange, if I use yocto fido the ETH2 works on both EVK.

Best Regards, Pedro


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 2 guests

cron