Error compiling input-utils_1.0.bb

Moderators: Oren.R, fradensky

y.yemelyanov
Posts: 19
Joined: Sat Mar 12, 2016 12:01 pm

Error compiling input-utils_1.0.bb

Postby y.yemelyanov » Sat Dec 24, 2016 1:49 pm

Hi,

I am trying to recompile Krogoth FS following this http://variwiki.com/index.php?title=VAR-SOM-AM33_Yocto_Krogoth_Build

I get this error, that I cannot resolve:

Code: Select all

ERROR: input-utils-1.0-r0 do_compile: oe_runmake failed
ERROR: input-utils-1.0-r0 do_compile: Function failed: do_compile (log file is located at /home/yuriy/yocto_varsomam33/tisdk/build/arago-tmp-external-linaro-toolchain/work/cortexa8hf-neon-linux-gnueabi/input-utils/1.0-r0/temp/log.do_compile.22824)
ERROR: Logfile of failure stored in: /home/yuriy/yocto_varsomam33/tisdk/build/arago-tmp-external-linaro-toolchain/work/cortexa8hf-neon-linux-gnueabi/input-utils/1.0-r0/temp/log.do_compile.22824
Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: make -j 2 DESTDIR=/home/yuriy/yocto_varsomam33/tisdk/build/arago-tmp-external-linaro-toolchain/work/cortexa8hf-neon-linux-gnueabi/input-utils/1.0-r0/image STRIP=
| Make.config:1: *** empty variable name.  Stop.
| WARNING: exit code 1 from a shell command.
| ERROR: oe_runmake failed
| ERROR: Function failed: do_compile (log file is located at /home/yuriy/yocto_varsomam33/tisdk/build/arago-tmp-external-linaro-toolchain/work/cortexa8hf-neon-linux-gnueabi/input-utils/1.0-r0/temp/log.do_compile.22824)
ERROR: Task 1919 (/home/yuriy/yocto_varsomam33/tisdk/sources/meta-arago/meta-arago-extras/recipes-devtools/input-utils/input-utils_1.0.bb, do_compile) failed with exit code '1'


I checked input-utils_1.0.bb recepie and it appers to match the original by tanglu.org.

Any ideas what I may be doing wrong?

fradensky
Posts: 41
Joined: Sun Nov 13, 2016 7:55 am

Re: Error compiling input-utils_1.0.bb

Postby fradensky » Sun Dec 25, 2016 5:27 am

Hi Yuriy

If your host system is Ubuntu, try changing default shell from dash to bash by running

dpkg-reconfigure dash

Felix.

y.yemelyanov
Posts: 19
Joined: Sat Mar 12, 2016 12:01 pm

Re: Error compiling input-utils_1.0.bb

Postby y.yemelyanov » Tue Dec 27, 2016 7:00 pm

Thanks, Felix.

I tried this as well as some other things and it didn't help.

Eventually I managed to get get it to compile on Ubuntu 14.04. instead of 16.04.


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 1 guest