Framebuffer

Moderators: Oren.R, Eran.M, fradensky

jonver
Posts: 3
Joined: Wed Aug 24, 2016 1:34 pm

Framebuffer

Postby jonver » Mon Sep 19, 2016 7:37 am

Hi,

I'm trying to create a framebuffer device by adding the following options to the device tree:

Code: Select all

/ {
    itdb28 {
      compatible = "ilitek,ili9325";
      status = "okay";

      rotate = <0>;
      bgr;
      buswidth = <8>;
      reset-gpios = <&gpio3 23 0>;
      dc-gpios = <&gpio3  5 0>;
      cs-gpios = <&gpio3  1 0>;
      wr-gpios = <&gpio3  0 0>;
      db-gpios = <&gpio3  7 0>,
            <&gpio3  8 0>,
            <&gpio3  9 0>,
            <&gpio3 10 0>,
            <&gpio3 11 0>,
            <&gpio3 15 0>,
            <&gpio3 16 0>,
            <&gpio3 17 0>;
      /* LED pin drives backlight directly. Use transistor (50mA) */
      /* led-gpios = <&gpio 4 1>; */
      debug = <7>;
   };


   framebuffer {
      compatible = "simple-framebuffer";
      reg = <0x1d385000 (240 * 320 * 2)>;
      width = <240>;
      height = <320>;
      stride = <(240 * 2)>;
      format = "r5g6b5";
   };
};


However, my boot log shows:

Code: Select all

Error opening /dev/fb0: No such file or directory


Any idea what is wrong? Do I need to enable kernel options or change u-boot boot arguments?

Thanks!

Eran.M
Posts: 140
Joined: Tue Jan 26, 2016 10:49 am

Re: Framebuffer

Postby Eran.M » Mon Sep 19, 2016 12:25 pm

You should already have a farmebuffer device.
Please try our latest recovery SD card: http://variwiki.com/index.php?title=DAR ... D_Recovery,
or build Yocto by following this page: http://variwiki.com/index.php?title=DAR ... o_R1_build

jonver
Posts: 3
Joined: Wed Aug 24, 2016 1:34 pm

Re: Framebuffer

Postby jonver » Mon Sep 19, 2016 12:30 pm

I have a framebuffer when i enable

Code: Select all

&lcdif {
   pinctrl-names = "default";
   pinctrl-0 = <&pinctrl_lcdif_dat
           &pinctrl_lcdif_ctrl>;
   display = <&display0>;
   status = "okay";
   display0: display {
      bits-per-pixel = <16>;
      bus-width = <8>;
      display-timings {
         native-mode = <&timing0>;
         timing0: timing0 {
            clock-frequency =<6000000>;
            hactive = <240>;
            vactive = <320>;
            hfront-porch = <0>;
            hback-porch = <0>;
            hsync-len = <0>;
            vback-porch = <14>;
            vfront-porch = <2>;
            vsync-len = <0>;
            hsync-active = <0>;
            vsync-active = <0>;
            de-active = <1>;
            pixelclk-active = <1>;
         };
      };
   };
};


But since i'm trying to use another display driver, this section is in comment and /dev/fb0 disappears


Return to “Yocto”

Who is online

Users browsing this forum: No registered users and 0 guests

cron